PDA

View Full Version : Sunset Riders - Graphic Glitches/"Jailbars"



mugenmidget
11-02-2014, 02:36 PM
I purchased a Sunset Riders board from Stryker28 at KLOV a while back that he had listed as "tested and working". When it arrived, the graphics appeared to be slightly garbled.

I let him know and he claimed it must have just "bumped around in the mail" as it was working when he tested it. He said I should try reseating/cleaning the ROMs. I did that with the five socketed ROMs (the ones with "064" stickers in my board pics) and didn't have any luck.

The mask ROM test in the game's service menu reports "7L" as bad, but I don't see any obvious damage around there. I've tried just generally brushing around the other graphics ROMs, board components, and the JAMMA connector clearing up as much dirt/corrosion as I could, but the corrupted graphics remain.

Any other ideas on what I could try/what to test? Has anyone encountered anything like this before? I'm definitely a scrub when it comes to arcade board repair/electronics so any help is appreciated.

I've attached some board pics and examples of the graphics issue.
20222

20223

20224

20225

20226

20227

20228

20229

20230

Fox1
11-02-2014, 02:41 PM
Mask roms can go bad just because, much like eproms over time. A good way to check is to desolder the mask rom, dump it and try it in mame to see if it reproduces the same effect. If it does, then you can replace the mask rom with a 27c400.

bustedstr8
11-02-2014, 02:42 PM
It's usually QFPs on these boards. You can gently press on them to see if the problem clears. I like to pick a chip press on it and then power on the board. If it's a bad connection the pressure can help reseat the pin well enough for the ROM to read.

If you find the QFP is bad it needs a reflow.

Atro
11-02-2014, 02:44 PM
I'd program an eprom and test it out on that 7L.
Or maybe it's just a broken trace from that particular rom that's causing trouble.

As a side note... damn dude! Must be hard to play an arcade game on composite...
Those pictures are bleeding badly.

mugenmidget
11-02-2014, 02:51 PM
I'd program an eprom and test it out on that 7L.
Or maybe it's just a broken trace from that particular rom that's causing trouble.

As a side note... damn dude! Must be hard to play an arcade game on composite...
Those pictures are bleeding badly.Haha, it's supposed to be S-Video, but I guess the encoder in this supergun is crappy. :) Just used it to get some screencaps, I normally play through RGB.

Thanks for the suggestions everyone. I don't have the equipment to dump or burn ROMs at the moment but I'll look into my options. I'll try pressing on the QFPs first and see if that helps.

Tyranix95
11-02-2014, 03:06 PM
Konami boards are flaky like that. Same thing happened to me, but with domestic seller a while back.


You have to start by checking mask rom at 7L with a programmer. If it's bad, then replace it. See what happens next.


If you wanna sell, FF2LMK. I may be interested. I think I can use the parts.

mugenmidget
11-02-2014, 03:12 PM
No luck with pushing on the QFPs just now. :( Guess I'll have to look into a programmer/someone local who might have one. Thanks again for the help.

bustedstr8
11-02-2014, 03:52 PM
Channelmaniac is in Dallas..maybe you can drop it off.

mugenmidget
11-02-2014, 04:11 PM
Ah, cool, thank you! I sent him a PM.

mainman
11-02-2014, 04:18 PM
7L is addressed by BOTH custom quads 245 and 244. One of three things has gone wrong here, either a broke trace between the mask and either of these quads or the mask has failed itself a slightly lesser chance of a broke trace from the quads to some other part in the circuit. A very easy and straight forward troubleshooting situation you have here. Just get a multi meter and buzz out the address, I/O and control lines from the mask to see if their still there and if they are then proceed to remove the mask and crc it against the mame dump.

channelmaniac
11-02-2014, 04:51 PM
Ah, cool, thank you! I sent him a PM.

You have a reply and an invitation to my shop. Some folks from the KLOV forums are coming over tonight to play in the shop. We're doing some trading and probably some repairs.

channelmaniac
11-06-2014, 11:23 PM
Straightened shorted bent pin on custom at 15H. Repaired bad trace between ROM at L7 and custom IC at 3J.

Plated thru hole failed.

mugenmidget
11-07-2014, 12:12 AM
Straightened shorted bent pin on custom at 15H. Repaired bad trace between ROM at L7 and custom IC at 3J.

Plated thru hole failed.Thanks so much! Was awesome to see your shop, really appreciate all the help. Sunset rides again. :)