PDA

View Full Version : Genesis S-Video mod: bad chroma



DanAdamKOF
12-29-2013, 03:42 AM
I've had a S-Video modded Genesis 1 that a member here modded a very long time ago. I haven't hooked it up much over the years and when I went to play it today it looked like this:
http://img.tapatalk.com/d/13/12/29/a8u5uraq.jpg
http://img.tapatalk.com/d/13/12/29/jyta4eqe.jpg
http://img.tapatalk.com/d/13/12/29/ujavejyp.jpg
http://img.tapatalk.com/d/13/12/29/nusa4aza.jpg
http://img.tapatalk.com/d/13/12/29/a9ahabu9.jpg
http://img.tapatalk.com/d/13/12/29/5ypy8edu.jpg
http://img.tapatalk.com/d/13/12/29/8ybe3e8u.jpg

Photos don't make it look as bad as it is in person.
There's also an interference pattern visible.

I'm guessing something got knocked loose during one of the times I've moved, I plan to open the system up and investigate it later. I'm pretty much posting this for others who may see the same thing later, and hopefully see my fix if I do fix this (I plan on it!).

And for the record I tested this by using multiple cartridges, bypassing my video switcher, using a different S-Video cable, and connecting another source to the input I was using to make sure my TV isn't messed up in general. The only thing I haven't tried is another PSU. Always remember to test before you freak out about stuff.

Lemony Vengeance
12-29-2013, 03:45 AM
man, tis the season for genny issues... :S

fluxcore
12-29-2013, 04:01 AM
The svideo mod itself is very simple (see http://www.jamma-nation-x.com/jammax/genesismods.html - just a transistor, capacitor, and a couple of resistors), so unless it's issues with the encoder chip itself, should be pretty easy to fix, I should think.

Xian Xi
12-29-2013, 05:38 AM
Looks like it's the old complicated S-video circuit since there's a bad palette and bleeding. Update it with the one on my site that viletim designed, link in above post.

DanAdamKOF
12-29-2013, 05:52 AM
It looks bad yes but it didn't used to look like this, again it's hard to convey in photos. Regardless I will look into re-modding with the above-linked circuit.

Shame as I just got Puyo Puyo recently but it's hard to play with the colors looking this bad.