PDA

View Full Version : NO SOUND Fatal Fury 2....



endgamer
01-07-2001, 11:05 PM
I bought this one off ebay from a seller I have bought from before so I know I can trust him. Cart, manual, insert and case are all near mint if not mint but it seems to output no sound.
I have tried all I know and I don't believe I have to clean the game contacts as they look new with no dirt or scratching. I have reset and restarted and tried all my other carts. It is the only one that will not give any sound.
Anyone have any ideas on what the problem is and what I can do about it. Thank you to all who answer. Much appreciated.

LWK
01-07-2001, 11:10 PM
its not your ff2 but the problem is in the system itself the original neo units had problems with fatal fury 2 in which snk offer to fix in 1993 picking up the sound rom is a problem....sorry or maybe you have anew style neo geo and the game is defective but I highly doubt it is

------------------
Who comes next to be my
goat

Silent_Scope
01-08-2001, 12:11 AM
It just reminds me I used to have exactly the same problem as your FF2 cart when it came out. The sound came on and off all the time so I returned the game back to Babbage's. It's SNK's fault not yours.

Dreamh2o
01-08-2001, 09:47 AM
Could be a dirty system, or the cart, to hard to tell without checking it all out first hand... If you need another FF2, I can set you up. email me.. tim@videogameland.com

NSX-T
01-11-2001, 04:53 PM
I have a FF2 aes cart that does not play music too.
NSX-T

NSX-T
01-18-2001, 05:50 PM
Hi Neo Geo fans,

Jeff K. or anybody,
If I use this FF2 as a sac. cart for Puzzle Bobble, will there be sound for PB?


NSX-T

[This message has been edited by NSX-T (edited January 18, 2001).]